re = /^[1-9]{1}[0-9]?([\.]?[0-9]+|[0-9]*)[GT]{1}$/m
str = '10.8G
5G
1.5G
15G
0
5
0.5
G
.G
.5G
1.G'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end