import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[1-9]{1}[0-9]?([\\.]?[0-9]+|[0-9]*)[GT]{1}$";
final String string = "10.8G\n"
+ "5G\n"
+ "1.5G\n"
+ "15G\n"
+ "0\n"
+ "5\n"
+ "0.5\n"
+ "G\n"
+ ".G\n"
+ ".5G\n"
+ "1.G";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}