// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[$](\s{0,1})|)[+-]?(\d{1,3},?(\d{3},?)*\d{3}(\.\d{0,2})?|\d{1,3}(\.\d{0,2})?|\.\d{1,2}?)$").unwrap();
let string = "//OK TESTS
0.12
2,000,000.00
$1.23
$ 1.23
-1233
$ -123
$-123
.12
$ .12
$-.12
//NEGATIVE TESTS
12.123
3.3.3
.2.2.
$$123.11
$12.$123
$ 123.2
.00.00
.0.0
...0
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}