import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[$](\\s{0,1})|)[+-]?(\\d{1,3},?(\\d{3},?)*\\d{3}(\\.\\d{0,2})?|\\d{1,3}(\\.\\d{0,2})?|\\.\\d{1,2}?)$";
final String string = "//OK TESTS\n"
+ "0.12\n"
+ "2,000,000.00\n"
+ "$1.23\n"
+ "$ 1.23\n"
+ "-1233\n"
+ "$ -123\n"
+ "$-123\n\n"
+ ".12\n"
+ "$ .12\n"
+ "$-.12\n\n"
+ "//NEGATIVE TESTS\n"
+ "12.123\n"
+ "3.3.3\n"
+ ".2.2.\n"
+ "$$123.11\n"
+ "$12.$123\n"
+ "$ 123.2\n"
+ ".00.00\n"
+ ".0.0\n"
+ "...0\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}