using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[$](\s{0,1})|)[+-]?(\d{1,3},?(\d{3},?)*\d{3}(\.\d{0,2})?|\d{1,3}(\.\d{0,2})?|\.\d{1,2}?)$";
string input = @"//OK TESTS
0.12
2,000,000.00
$1.23
$ 1.23
-1233
$ -123
$-123
.12
$ .12
$-.12
//NEGATIVE TESTS
12.123
3.3.3
.2.2.
$$123.11
$12.$123
$ 123.2
.00.00
.0.0
...0
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}