# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[$](\s{0,1})|)[+-]?(\d{1,3},?(\d{3},?)*\d{3}(\.\d{0,2})?|\d{1,3}(\.\d{0,2})?|\.\d{1,2}?)$"
test_str = ("//OK TESTS\n"
"0.12\n"
"2,000,000.00\n"
"$1.23\n"
"$ 1.23\n"
"-1233\n"
"$ -123\n"
"$-123\n\n"
".12\n"
"$ .12\n"
"$-.12\n\n"
"//NEGATIVE TESTS\n"
"12.123\n"
"3.3.3\n"
".2.2.\n"
"$$123.11\n"
"$12.$123\n"
"$ 123.2\n"
".00.00\n"
".0.0\n"
"...0\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.