package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[$](\s{0,1})|)[+-]?(\d{1,3},?(\d{3},?)*\d{3}(\.\d{0,2})?|\d{1,3}(\.\d{0,2})?|\.\d{1,2}?)$`)
var str = `//OK TESTS
0.12
2,000,000.00
$1.23
$ 1.23
-1233
$ -123
$-123
.12
$ .12
$-.12
//NEGATIVE TESTS
12.123
3.3.3
.2.2.
$$123.11
$12.$123
$ 123.2
.00.00
.0.0
...0
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}