const regex = /^(?:[$](\s{0,1})|)[+-]?(\d{1,3},?(\d{3},?)*\d{3}(\.\d{0,2})?|\d{1,3}(\.\d{0,2})?|\.\d{1,2}?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[$](\\s{0,1})|)[+-]?(\\d{1,3},?(\\d{3},?)*\\d{3}(\\.\\d{0,2})?|\\d{1,3}(\\.\\d{0,2})?|\\.\\d{1,2}?)$', 'gm')
const str = `//OK TESTS
0.12
2,000,000.00
\$1.23
\$ 1.23
-1233
\$ -123
\$-123
.12
\$ .12
\$-.12
//NEGATIVE TESTS
12.123
3.3.3
.2.2.
\$\$123.11
\$12.\$123
\$ 123.2
.00.00
.0.0
...0
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}