#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[$](\s{0,1})|)[+-]?(\d{1,3},?(\d{3},?)*\d{3}(\.\d{0,2})?|\d{1,3}(\.\d{0,2})?|\.\d{1,2}?)$"
Local $sString = "//OK TESTS" & @CRLF & _
"0.12" & @CRLF & _
"2,000,000.00" & @CRLF & _
"$1.23" & @CRLF & _
"$ 1.23" & @CRLF & _
"-1233" & @CRLF & _
"$ -123" & @CRLF & _
"$-123" & @CRLF & _
"" & @CRLF & _
".12" & @CRLF & _
"$ .12" & @CRLF & _
"$-.12" & @CRLF & _
"" & @CRLF & _
"//NEGATIVE TESTS" & @CRLF & _
"12.123" & @CRLF & _
"3.3.3" & @CRLF & _
".2.2." & @CRLF & _
"$$123.11" & @CRLF & _
"$12.$123" & @CRLF & _
"$ 123.2" & @CRLF & _
".00.00" & @CRLF & _
".0.0" & @CRLF & _
"...0" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")