import Foundation
let pattern = #"(?:https|http){0,1}(?:[:\/]*)(?:[w]{3}\.){0,1}(?:[A-z\.]*)(?:linkedin\.com){0,1}(\/{1}.+\/{1}.+?)(?:\/)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Should match
https://www.linkedin.com/in/ricardo-alvares
https://www.linkedincom/in/ricardo-alvares
www.linkedin.com/in/ricardo-alvares
linkedin.com/in/ricardo-alvares
Shouldn't match
https://www.linkedin.com/pub/s/whatever/1230/no/good
https:/example.com/some/resource/in/should/not/match
/pub/s/whatever/1230/no/good
pub/s/whatever/1230/no/good
/some/resource/in/should/not/match
some/resource/in/should/not/match
Don't know about these:
/in/ricardo-alvares
in/ricardo-alvares
/doubtfulmatch/in/ricardo-alvares
doubtfulmatch/in/ricardo-alvares
https://www.linkedin.com/in/ricardo-alvares/some-action
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)