// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:https|http){0,1}(?:[:\/]*)(?:[w]{3}\.){0,1}(?:[A-z\.]*)(?:linkedin\.com){0,1}(\/{1}.+\/{1}.+?)(?:\/)*$").unwrap();
let string = "Should match
https://www.linkedin.com/in/ricardo-alvares
https://www.linkedincom/in/ricardo-alvares
www.linkedin.com/in/ricardo-alvares
linkedin.com/in/ricardo-alvares
Shouldn't match
https://www.linkedin.com/pub/s/whatever/1230/no/good
https:/example.com/some/resource/in/should/not/match
/pub/s/whatever/1230/no/good
pub/s/whatever/1230/no/good
/some/resource/in/should/not/match
some/resource/in/should/not/match
Don't know about these:
/in/ricardo-alvares
in/ricardo-alvares
/doubtfulmatch/in/ricardo-alvares
doubtfulmatch/in/ricardo-alvares
https://www.linkedin.com/in/ricardo-alvares/some-action";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}