import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:https|http){0,1}(?:[:\\/]*)(?:[w]{3}\\.){0,1}(?:[A-z\\.]*)(?:linkedin\\.com){0,1}(\\/{1}.+\\/{1}.+?)(?:\\/)*$";
final String string = "Should match\n"
+ "https://www.linkedin.com/in/ricardo-alvares\n"
+ "https://www.linkedincom/in/ricardo-alvares\n"
+ "www.linkedin.com/in/ricardo-alvares\n"
+ "linkedin.com/in/ricardo-alvares\n\n"
+ "Shouldn't match\n"
+ "https://www.linkedin.com/pub/s/whatever/1230/no/good\n"
+ "https:/example.com/some/resource/in/should/not/match\n"
+ "/pub/s/whatever/1230/no/good\n"
+ "pub/s/whatever/1230/no/good\n"
+ "/some/resource/in/should/not/match\n"
+ "some/resource/in/should/not/match\n\n"
+ "Don't know about these:\n"
+ "/in/ricardo-alvares\n"
+ "in/ricardo-alvares\n"
+ "/doubtfulmatch/in/ricardo-alvares\n"
+ "doubtfulmatch/in/ricardo-alvares\n"
+ "https://www.linkedin.com/in/ricardo-alvares/some-action";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}