#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:https|http){0,1}(?:[:\/]*)(?:[w]{3}\.){0,1}(?:[A-z\.]*)(?:linkedin\.com){0,1}(\/{1}.+\/{1}.+?)(?:\/)*$"
Local $sString = "Should match" & @CRLF & _
"https://www.linkedin.com/in/ricardo-alvares" & @CRLF & _
"https://www.linkedincom/in/ricardo-alvares" & @CRLF & _
"www.linkedin.com/in/ricardo-alvares" & @CRLF & _
"linkedin.com/in/ricardo-alvares" & @CRLF & _
"" & @CRLF & _
"Shouldn't match" & @CRLF & _
"https://www.linkedin.com/pub/s/whatever/1230/no/good" & @CRLF & _
"https:/example.com/some/resource/in/should/not/match" & @CRLF & _
"/pub/s/whatever/1230/no/good" & @CRLF & _
"pub/s/whatever/1230/no/good" & @CRLF & _
"/some/resource/in/should/not/match" & @CRLF & _
"some/resource/in/should/not/match" & @CRLF & _
"" & @CRLF & _
"Don't know about these:" & @CRLF & _
"/in/ricardo-alvares" & @CRLF & _
"in/ricardo-alvares" & @CRLF & _
"/doubtfulmatch/in/ricardo-alvares" & @CRLF & _
"doubtfulmatch/in/ricardo-alvares" & @CRLF & _
"https://www.linkedin.com/in/ricardo-alvares/some-action"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")