const regex = /(?:https|http){0,1}(?:[:\/]*)(?:[w]{3}\.){0,1}(?:[A-z\.]*)(?:linkedin\.com){0,1}(\/{1}.+\/{1}.+?)(?:\/)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:https|http){0,1}(?:[:\\\/]*)(?:[w]{3}\\.){0,1}(?:[A-z\\.]*)(?:linkedin\\.com){0,1}(\\\/{1}.+\\\/{1}.+?)(?:\\\/)*$', 'gm')
const str = `Should match
https://www.linkedin.com/in/ricardo-alvares
https://www.linkedincom/in/ricardo-alvares
www.linkedin.com/in/ricardo-alvares
linkedin.com/in/ricardo-alvares
Shouldn't match
https://www.linkedin.com/pub/s/whatever/1230/no/good
https:/example.com/some/resource/in/should/not/match
/pub/s/whatever/1230/no/good
pub/s/whatever/1230/no/good
/some/resource/in/should/not/match
some/resource/in/should/not/match
Don't know about these:
/in/ricardo-alvares
in/ricardo-alvares
/doubtfulmatch/in/ricardo-alvares
doubtfulmatch/in/ricardo-alvares
https://www.linkedin.com/in/ricardo-alvares/some-action`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}