use strict;
my $str = 'Should match
https://www.linkedin.com/in/ricardo-alvares
https://www.linkedincom/in/ricardo-alvares
www.linkedin.com/in/ricardo-alvares
linkedin.com/in/ricardo-alvares
Shouldn\'t match
https://www.linkedin.com/pub/s/whatever/1230/no/good
https:/example.com/some/resource/in/should/not/match
/pub/s/whatever/1230/no/good
pub/s/whatever/1230/no/good
/some/resource/in/should/not/match
some/resource/in/should/not/match
Don\'t know about these:
/in/ricardo-alvares
in/ricardo-alvares
/doubtfulmatch/in/ricardo-alvares
doubtfulmatch/in/ricardo-alvares
https://www.linkedin.com/in/ricardo-alvares/some-action';
my $regex = qr/(?:https|http){0,1}(?:[:\/]*)(?:[w]{3}\.){0,1}(?:[A-z\.]*)(?:linkedin\.com){0,1}(\/{1}.+\/{1}.+?)(?:\/)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}