package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:https|http){0,1}(?:[:\/]*)(?:[w]{3}\.){0,1}(?:[A-z\.]*)(?:linkedin\.com){0,1}(\/{1}.+\/{1}.+?)(?:\/)*$`)
var str = `Should match
https://www.linkedin.com/in/ricardo-alvares
https://www.linkedincom/in/ricardo-alvares
www.linkedin.com/in/ricardo-alvares
linkedin.com/in/ricardo-alvares
Shouldn't match
https://www.linkedin.com/pub/s/whatever/1230/no/good
https:/example.com/some/resource/in/should/not/match
/pub/s/whatever/1230/no/good
pub/s/whatever/1230/no/good
/some/resource/in/should/not/match
some/resource/in/should/not/match
Don't know about these:
/in/ricardo-alvares
in/ricardo-alvares
/doubtfulmatch/in/ricardo-alvares
doubtfulmatch/in/ricardo-alvares
https://www.linkedin.com/in/ricardo-alvares/some-action`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}