re = /filename="?(\S*\.\w*)/i
str = '
attachment; filename="科学上网.pdf"; filename*=utf-8\'\'科学上网.pdf
attachment; fileName=科学上网.pdf'
# Print the match result
str.match(re) do |match|
puts match.to_s
end