import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "filename=\"?(\\S*\\.\\w*)";
final String string = "\n"
+ "attachment; filename=\"科学上网.pdf\"; filename*=utf-8''科学上网.pdf\n\n\n"
+ "attachment; fileName=科学上网.pdf";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}