$re = '/filename="?(\S*\.\w*)/i';
$str = '
attachment; filename="科学上网.pdf"; filename*=utf-8\'\'科学上网.pdf
attachment; fileName=科学上网.pdf';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);