package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)filename="?(\S*\.\w*)`)
var str = `
attachment; filename="科学上网.pdf"; filename*=utf-8''科学上网.pdf
attachment; fileName=科学上网.pdf`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}