using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"filename=""?(\S*\.\w*)";
string input = @"
attachment; filename=""科学上网.pdf""; filename*=utf-8''科学上网.pdf
attachment; fileName=科学上网.pdf";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}