#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)filename="?(\S*\.\w*)"
Local $sString = "" & @CRLF & _
"attachment; filename="科学上网.pdf"; filename*=utf-8''科学上网.pdf" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"attachment; fileName=科学上网.pdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")