const regex = /filename="?(\S*\.\w*)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('filename="?(\\S*\\.\\w*)', 'i')
const str = `
attachment; filename="科学上网.pdf"; filename*=utf-8''科学上网.pdf
attachment; fileName=科学上网.pdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}