import Foundation
let pattern = #"(\w+)\|(?=(?:\w+\|)*\w+=(\w+))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
BBB|CCC|DDD=AAA
FFF|GGG|HHH|III|JJJ|KKK=EEE
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1=$2\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)