# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w+)\|(?=(?:\w+\|)*\w+=(\w+))/$1=$2\n/gm;t' <<< "BBB|CCC|DDD=AAA
FFF|GGG|HHH|III|JJJ|KKK=EEE"