$re = '/(\w+)\|(?=(?:\w+\|)*\w+=(\w+))/m';
$str = 'BBB|CCC|DDD=AAA
FFF|GGG|HHH|III|JJJ|KKK=EEE';
$subst = "$1=$2\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;