#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\w+)\|(?=(?:\w+\|)*\w+=(\w+))"
Local $sString = "BBB|CCC|DDD=AAA" & @CRLF & _
"FFF|GGG|HHH|III|JJJ|KKK=EEE"
Local $sSubst = "$1=$2\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)