using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)\|(?=(?:\w+\|)*\w+=(\w+))";
string substitution = @"$1=$2\n";
string input = @"BBB|CCC|DDD=AAA
FFF|GGG|HHH|III|JJJ|KKK=EEE";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}