const regex = /(\w+)\|(?=(?:\w+\|)*\w+=(\w+))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+)\\|(?=(?:\\w+\\|)*\\w+=(\\w+))', 'gm')
const str = `BBB|CCC|DDD=AAA
FFF|GGG|HHH|III|JJJ|KKK=EEE`;
const subst = `$1=$2\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);