re = /(\w+)\|(?=(?:\w+\|)*\w+=(\w+))/m
str = 'BBB|CCC|DDD=AAA
FFF|GGG|HHH|III|JJJ|KKK=EEE'
subst = '$1=$2\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result