re = /^(.*?)\/(?<mnemonic>.{2,8}?)_(?<isbn>\d{13})_(?<primaryId>.+?)_(?<secondaryId>tcx\d{0,3})(?:_r(?<revisionNumber>\d+))?\.(?<extension>indd|qxp|qxd)$/m
str = 'Obam_9781524763138_all_tcx_r3 Folder/Obam_9781524763138_all_tcx_r3.indd
Obam_9781524763138_all_tcx1_r3 Folder/Obam_9781524763138_all_tcx1_r3.indd
Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_all_tcx12_r3.indd
Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_all_tcx123_r3.indd
Obam_9781524763138_all_tcx1234_r3 Folder/Obam_9781524763138_all_tcx1234_r3.indd
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end