#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*?)\/(?<mnemonic>.{2,8}?)_(?<isbn>\d{13})_(?<primaryId>.+?)_(?<secondaryId>tcx\d{0,3})(?:_r(?<revisionNumber>\d+))?\.(?<extension>indd|qxp|qxd)$"
Local $sString = "Obam_9781524763138_all_tcx_r3 Folder/Obam_9781524763138_all_tcx_r3.indd" & @CRLF & _
"Obam_9781524763138_all_tcx1_r3 Folder/Obam_9781524763138_all_tcx1_r3.indd" & @CRLF & _
"Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_all_tcx12_r3.indd" & @CRLF & _
"Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_all_tcx123_r3.indd" & @CRLF & _
"Obam_9781524763138_all_tcx1234_r3 Folder/Obam_9781524763138_all_tcx1234_r3.indd" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")