package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?)\/(?<mnemonic>.{2,8}?)_(?<isbn>\d{13})_(?<primaryId>.+?)_(?<secondaryId>tcx\d{0,3})(?:_r(?<revisionNumber>\d+))?\.(?<extension>indd|qxp|qxd)$`)
var str = `Obam_9781524763138_all_tcx_r3 Folder/Obam_9781524763138_all_tcx_r3.indd
Obam_9781524763138_all_tcx1_r3 Folder/Obam_9781524763138_all_tcx1_r3.indd
Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_all_tcx12_r3.indd
Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_all_tcx123_r3.indd
Obam_9781524763138_all_tcx1234_r3 Folder/Obam_9781524763138_all_tcx1234_r3.indd
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}