use strict;
my $str = 'Obam_9781524763138_all_tcx_r3 Folder/Obam_9781524763138_all_tcx_r3.indd
Obam_9781524763138_all_tcx1_r3 Folder/Obam_9781524763138_all_tcx1_r3.indd
Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_all_tcx12_r3.indd
Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_all_tcx123_r3.indd
Obam_9781524763138_all_tcx1234_r3 Folder/Obam_9781524763138_all_tcx1234_r3.indd
';
my $regex = qr/^(.*?)\/(?<mnemonic>.{2,8}?)_(?<isbn>\d{13})_(?<primaryId>.+?)_(?<secondaryId>tcx\d{0,3})(?:_r(?<revisionNumber>\d+))?\.(?<extension>indd|qxp|qxd)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}