import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?)\\/(?<mnemonic>.{2,8}?)_(?<isbn>\\d{13})_(?<primaryId>.+?)_(?<secondaryId>tcx\\d{0,3})(?:_r(?<revisionNumber>\\d+))?\\.(?<extension>indd|qxp|qxd)$";
final String string = "Obam_9781524763138_all_tcx_r3 Folder/Obam_9781524763138_all_tcx_r3.indd\n"
+ "Obam_9781524763138_all_tcx1_r3 Folder/Obam_9781524763138_all_tcx1_r3.indd\n"
+ "Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_all_tcx12_r3.indd\n"
+ "Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_all_tcx123_r3.indd\n"
+ "Obam_9781524763138_all_tcx1234_r3 Folder/Obam_9781524763138_all_tcx1234_r3.indd\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}