using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?)\/(?<mnemonic>.{2,8}?)_(?<isbn>\d{13})_(?<primaryId>.+?)_(?<secondaryId>tcx\d{0,3})(?:_r(?<revisionNumber>\d+))?\.(?<extension>indd|qxp|qxd)$";
string input = @"Obam_9781524763138_all_tcx_r3 Folder/Obam_9781524763138_all_tcx_r3.indd
Obam_9781524763138_all_tcx1_r3 Folder/Obam_9781524763138_all_tcx1_r3.indd
Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_all_tcx12_r3.indd
Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_all_tcx123_r3.indd
Obam_9781524763138_all_tcx1234_r3 Folder/Obam_9781524763138_all_tcx1234_r3.indd
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}