import Foundation
let pattern = #"(?<=href=\").+?(?=\")"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<li><a href="Submissions%253ASpatioTemporalExtent.html" title="Submissions:SpatioTemporalExtent"> Submissions:SpatioTemporalExtent </a></li><li><a href="Submissions%253AParticipantRole.html" title="Submissions:ParticipantRole"> Submissions:ParticipantRole </a></li><li><a href="Submissions%253AAgentRole.html" title="Submissions:AgentRole"> Submissions:AgentRole </a></li><li><a href="Submissions%253AObjectrole.html" title="Submissions:Objectrole"> Submissions:Objectrole </a></li><li><a href="Submissions%253AInformation_realization.html" title="Submissions:Information realization"> Submissions:Information realization </a></li><li><a href="Submissions%253AInformationObjectsAndRepresentationLanguages.html" title="Submissions:InformationObjectsAndRepresentationLanguages"> Submissions:InformationObjectsAndRepresentationLanguages </a></li><li><a class="new" href="http://ontologydesignpatterns.org/wiki/index.php?title=Submissions:InformationObject&action=edit&redlink=1" title="Submissions:InformationObject (not yet written)"> Submissions:InformationObject </a></li><li><a href="Submissions%253AEventProcessing.html" title="Submissions:EventProcessing"> Submissions:EventProcessing </a></li>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)