$re = '/(?<=href=\").+?(?=\")/m';
$str = '<li><a href="Submissions%253ASpatioTemporalExtent.html" title="Submissions:SpatioTemporalExtent"> Submissions:SpatioTemporalExtent </a></li><li><a href="Submissions%253AParticipantRole.html" title="Submissions:ParticipantRole"> Submissions:ParticipantRole </a></li><li><a href="Submissions%253AAgentRole.html" title="Submissions:AgentRole"> Submissions:AgentRole </a></li><li><a href="Submissions%253AObjectrole.html" title="Submissions:Objectrole"> Submissions:Objectrole </a></li><li><a href="Submissions%253AInformation_realization.html" title="Submissions:Information realization"> Submissions:Information realization </a></li><li><a href="Submissions%253AInformationObjectsAndRepresentationLanguages.html" title="Submissions:InformationObjectsAndRepresentationLanguages"> Submissions:InformationObjectsAndRepresentationLanguages </a></li><li><a class="new" href="http://ontologydesignpatterns.org/wiki/index.php?title=Submissions:InformationObject&action=edit&redlink=1" title="Submissions:InformationObject (not yet written)"> Submissions:InformationObject </a></li><li><a href="Submissions%253AEventProcessing.html" title="Submissions:EventProcessing"> Submissions:EventProcessing </a></li>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);