using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=href=\"").+?(?=\"")";
string input = @"<li><a href=""Submissions%253ASpatioTemporalExtent.html"" title=""Submissions:SpatioTemporalExtent""> Submissions:SpatioTemporalExtent </a></li><li><a href=""Submissions%253AParticipantRole.html"" title=""Submissions:ParticipantRole""> Submissions:ParticipantRole </a></li><li><a href=""Submissions%253AAgentRole.html"" title=""Submissions:AgentRole""> Submissions:AgentRole </a></li><li><a href=""Submissions%253AObjectrole.html"" title=""Submissions:Objectrole""> Submissions:Objectrole </a></li><li><a href=""Submissions%253AInformation_realization.html"" title=""Submissions:Information realization""> Submissions:Information realization </a></li><li><a href=""Submissions%253AInformationObjectsAndRepresentationLanguages.html"" title=""Submissions:InformationObjectsAndRepresentationLanguages""> Submissions:InformationObjectsAndRepresentationLanguages </a></li><li><a class=""new"" href=""http://ontologydesignpatterns.org/wiki/index.php?title=Submissions:InformationObject&action=edit&redlink=1"" title=""Submissions:InformationObject (not yet written)""> Submissions:InformationObject </a></li><li><a href=""Submissions%253AEventProcessing.html"" title=""Submissions:EventProcessing""> Submissions:EventProcessing </a></li>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}