#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=href=\").+?(?=\")"
Local $sString = "<li><a href="Submissions%253ASpatioTemporalExtent.html" title="Submissions:SpatioTemporalExtent"> Submissions:SpatioTemporalExtent </a></li><li><a href="Submissions%253AParticipantRole.html" title="Submissions:ParticipantRole"> Submissions:ParticipantRole </a></li><li><a href="Submissions%253AAgentRole.html" title="Submissions:AgentRole"> Submissions:AgentRole </a></li><li><a href="Submissions%253AObjectrole.html" title="Submissions:Objectrole"> Submissions:Objectrole </a></li><li><a href="Submissions%253AInformation_realization.html" title="Submissions:Information realization"> Submissions:Information realization </a></li><li><a href="Submissions%253AInformationObjectsAndRepresentationLanguages.html" title="Submissions:InformationObjectsAndRepresentationLanguages"> Submissions:InformationObjectsAndRepresentationLanguages </a></li><li><a class="new" href="http://ontologydesignpatterns.org/wiki/index.php?title=Submissions:InformationObject&action=edit&redlink=1" title="Submissions:InformationObject (not yet written)"> Submissions:InformationObject </a></li><li><a href="Submissions%253AEventProcessing.html" title="Submissions:EventProcessing"> Submissions:EventProcessing </a></li>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")