const regex = new RegExp('(?<=href=\\").+?(?=\\")', 'gm')
const str = `<li><a href="Submissions%253ASpatioTemporalExtent.html" title="Submissions:SpatioTemporalExtent"> Submissions:SpatioTemporalExtent </a></li><li><a href="Submissions%253AParticipantRole.html" title="Submissions:ParticipantRole"> Submissions:ParticipantRole </a></li><li><a href="Submissions%253AAgentRole.html" title="Submissions:AgentRole"> Submissions:AgentRole </a></li><li><a href="Submissions%253AObjectrole.html" title="Submissions:Objectrole"> Submissions:Objectrole </a></li><li><a href="Submissions%253AInformation_realization.html" title="Submissions:Information realization"> Submissions:Information realization </a></li><li><a href="Submissions%253AInformationObjectsAndRepresentationLanguages.html" title="Submissions:InformationObjectsAndRepresentationLanguages"> Submissions:InformationObjectsAndRepresentationLanguages </a></li><li><a class="new" href="http://ontologydesignpatterns.org/wiki/index.php?title=Submissions:InformationObject&action=edit&redlink=1" title="Submissions:InformationObject (not yet written)"> Submissions:InformationObject </a></li><li><a href="Submissions%253AEventProcessing.html" title="Submissions:EventProcessing"> Submissions:EventProcessing </a></li>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}