import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=href=\\\").+?(?=\\\")";
final String string = "<li><a href=\"Submissions%253ASpatioTemporalExtent.html\" title=\"Submissions:SpatioTemporalExtent\"> Submissions:SpatioTemporalExtent </a></li><li><a href=\"Submissions%253AParticipantRole.html\" title=\"Submissions:ParticipantRole\"> Submissions:ParticipantRole </a></li><li><a href=\"Submissions%253AAgentRole.html\" title=\"Submissions:AgentRole\"> Submissions:AgentRole </a></li><li><a href=\"Submissions%253AObjectrole.html\" title=\"Submissions:Objectrole\"> Submissions:Objectrole </a></li><li><a href=\"Submissions%253AInformation_realization.html\" title=\"Submissions:Information realization\"> Submissions:Information realization </a></li><li><a href=\"Submissions%253AInformationObjectsAndRepresentationLanguages.html\" title=\"Submissions:InformationObjectsAndRepresentationLanguages\"> Submissions:InformationObjectsAndRepresentationLanguages </a></li><li><a class=\"new\" href=\"http://ontologydesignpatterns.org/wiki/index.php?title=Submissions:InformationObject&action=edit&redlink=1\" title=\"Submissions:InformationObject (not yet written)\"> Submissions:InformationObject </a></li><li><a href=\"Submissions%253AEventProcessing.html\" title=\"Submissions:EventProcessing\"> Submissions:EventProcessing </a></li>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}