use strict;
my $str = '<li><a href="Submissions%253ASpatioTemporalExtent.html" title="Submissions:SpatioTemporalExtent"> Submissions:SpatioTemporalExtent </a></li><li><a href="Submissions%253AParticipantRole.html" title="Submissions:ParticipantRole"> Submissions:ParticipantRole </a></li><li><a href="Submissions%253AAgentRole.html" title="Submissions:AgentRole"> Submissions:AgentRole </a></li><li><a href="Submissions%253AObjectrole.html" title="Submissions:Objectrole"> Submissions:Objectrole </a></li><li><a href="Submissions%253AInformation_realization.html" title="Submissions:Information realization"> Submissions:Information realization </a></li><li><a href="Submissions%253AInformationObjectsAndRepresentationLanguages.html" title="Submissions:InformationObjectsAndRepresentationLanguages"> Submissions:InformationObjectsAndRepresentationLanguages </a></li><li><a class="new" href="http://ontologydesignpatterns.org/wiki/index.php?title=Submissions:InformationObject&action=edit&redlink=1" title="Submissions:InformationObject (not yet written)"> Submissions:InformationObject </a></li><li><a href="Submissions%253AEventProcessing.html" title="Submissions:EventProcessing"> Submissions:EventProcessing </a></li>';
my $regex = qr/(?<=href=\").+?(?=\")/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}