import Foundation
let pattern = #"ETag\s+:\s([0-9a-z-]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Name : voip_asterisk.gif
Date : 2019-08-12 17:37:20 +0430
Size : 4.3 KiB
ETag : aa28b23fe87c20761b137965f93b8bea-1
Type : file
Metadata :
Content-Type : image/gif
X-Minio-Deployment-Id: 19531601-d904-401a-9ffe-57e85a0d91a1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)