#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)ETag\s+:\s([0-9a-z-]+)"
Local $sString = "Name : voip_asterisk.gif" & @CRLF & _
"Date : 2019-08-12 17:37:20 +0430" & @CRLF & _
"Size : 4.3 KiB" & @CRLF & _
"ETag : aa28b23fe87c20761b137965f93b8bea-1" & @CRLF & _
"Type : file" & @CRLF & _
"Metadata :" & @CRLF & _
" Content-Type : image/gif" & @CRLF & _
" X-Minio-Deployment-Id: 19531601-d904-401a-9ffe-57e85a0d91a1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")