use strict;
my $str = 'Name : voip_asterisk.gif
Date : 2019-08-12 17:37:20 +0430
Size : 4.3 KiB
ETag : aa28b23fe87c20761b137965f93b8bea-1
Type : file
Metadata :
Content-Type : image/gif
X-Minio-Deployment-Id: 19531601-d904-401a-9ffe-57e85a0d91a1';
my $regex = qr/ETag\s+:\s([0-9a-z-]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}