// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)ETag\s+:\s([0-9a-z-]+)").unwrap();
let string = "Name : voip_asterisk.gif
Date : 2019-08-12 17:37:20 +0430
Size : 4.3 KiB
ETag : aa28b23fe87c20761b137965f93b8bea-1
Type : file
Metadata :
Content-Type : image/gif
X-Minio-Deployment-Id: 19531601-d904-401a-9ffe-57e85a0d91a1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}