package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)ETag\s+:\s([0-9a-z-]+)`)
var str = `Name : voip_asterisk.gif
Date : 2019-08-12 17:37:20 +0430
Size : 4.3 KiB
ETag : aa28b23fe87c20761b137965f93b8bea-1
Type : file
Metadata :
Content-Type : image/gif
X-Minio-Deployment-Id: 19531601-d904-401a-9ffe-57e85a0d91a1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}