# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"ETag\s+:\s([0-9a-z-]+)"
test_str = ("Name : voip_asterisk.gif\n"
"Date : 2019-08-12 17:37:20 +0430\n"
"Size : 4.3 KiB\n"
"ETag : aa28b23fe87c20761b137965f93b8bea-1\n"
"Type : file\n"
"Metadata :\n"
" Content-Type : image/gif\n"
" X-Minio-Deployment-Id: 19531601-d904-401a-9ffe-57e85a0d91a1")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.