import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ETag\\s+:\\s([0-9a-z-]+)";
final String string = "Name : voip_asterisk.gif\n"
+ "Date : 2019-08-12 17:37:20 +0430\n"
+ "Size : 4.3 KiB\n"
+ "ETag : aa28b23fe87c20761b137965f93b8bea-1\n"
+ "Type : file\n"
+ "Metadata :\n"
+ " Content-Type : image/gif\n"
+ " X-Minio-Deployment-Id: 19531601-d904-401a-9ffe-57e85a0d91a1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}